Easy Social Share Buttons is fully compatible with version 7 of PHP and you can safely migrate. We made wide range of tests using all latest PHP 7.0, PHP 7.1 and PHP 7.2 builds to ensure this. If you run PHP Compatibility Checker plugin and see messages appearing consider them as false positive.  Compatibility Checker uses regular text scan but plugin code is made to run depending of PHP version which ensures that you will have no problems. The version based code loading is used to allow support of legacy PHP versions for other customers that does not have option to migrate to PHP 7 (plugin supports all versions of PHP since 5.2).

Feel safe to migrate to PHP 7 and you will have no problems generated from Easy Social Share Buttons – in fact plugin will work better because we always use latest code optimization techniques.